Extra VLANS on physical infra for vSphere lab (7-SEP-2015)

Introduction

In order to study for the VCIX-NV exam I needed to add some more VLANS that I can use in my vSphere environment, to my physical environment.

pub?w=1655&h=935&.png

The change

CS1

Adding VLANS

!
vlan 22
 name VLAN22
!
vlan 33
 name VLAN33
!
vlan 44
 name VLAN44
!
vlan 55
 name VLAN55
!
vlan 66
 name VLAN66
!

Adding L3 VLAN interfaces (SVI's)

!
interface Vlan22
 ip address 10.22.22.253 255.255.255.0
!
interface Vlan33
 ip address 10.33.33.253 255.255.255.0
! 
interface Vlan44
 ip address 10.44.44.253 255.255.255.0
!
interface Vlan55
 ip address 10.55.55.253 255.255.255.0
!
interface Vlan66
 ip address 10.66.66.253 255.255.255.0
! 

Adding DHCP Scopes

!
ip dhcp pool VLAN22
   import all
   network 10.22.22.0 255.255.255.0
   default-router 10.22.22.253 
   dns-server 8.8.8.8 8.8.4.4 208.67.222.222 208.67.220.220 
!
ip dhcp pool VLAN33
   import all
   network 10.33.33.0 255.255.255.0
   default-router 10.33.33.253 
   dns-server 8.8.8.8 8.8.4.4 208.67.222.222 208.67.220.220 
!
ip dhcp pool VLAN44
   import all
   network 10.44.44.0 255.255.255.0
   default-router 10.44.44.253 
   dns-server 8.8.8.8 8.8.4.4 208.67.222.222 208.67.220.220 
!
ip dhcp pool VLAN55
   import all
   network 10.55.55.0 255.255.255.0
   default-router 10.55.55.253 
   dns-server 8.8.8.8 8.8.4.4 208.67.222.222 208.67.220.220 
!
ip dhcp pool VLAN66
   import all
   network 10.66.66.0 255.255.255.0
   default-router 10.66.66.253 
   dns-server 8.8.8.8 8.8.4.4 208.67.222.222 208.67.220.220 
!

AS2

Adding VLANS

!
vlan 22
 name VLAN22
!
vlan 33
 name VLAN33
! 
vlan 44
 name VLAN44
! 
vlan 55
 name VLAN55
! 
vlan 66
 name VLAN66
! 

Adding VLANS to the trunk towards the ESX server

!
interface GigabitEthernet1/18
 description NL-RTD01-ESX02-INT1
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 11
 switchport trunk allowed vlan 11,33,55
 switchport mode trunk
!
interface GigabitEthernet1/34
 description NL-RTD01-ESX02-INT2
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 11
 switchport trunk allowed vlan 22,44,66
 switchport mode trunk
!

FW1

Adding static routing entries

Because the default gateway for all 10.11.11.0/24 hosts is set to the firewall (10.11.11.254) I need to make an some static route entries in the firewall so that the new networks can still be found.

route inside 10.22.22.0 255.255.255.0 10.11.11.253 1
route inside 10.33.33.0 255.255.255.0 10.11.11.253 1
route inside 10.44.44.0 255.255.255.0 10.11.11.253 1
route inside 10.55.55.0 255.255.255.0 10.11.11.253 1
route inside 10.66.66.0 255.255.255.0 10.11.11.253 1